A Photography forum. PhotoBanter.com

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » PhotoBanter.com forum » General Photography » In The Darkroom
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

fourier plug-in for gimp



 
 
Thread Tools Display Modes
  #1  
Old October 22nd 14, 09:44 PM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
Dale[_2_]
external usenet poster
 
Posts: 137
Default fourier plug-in for gimp

having troubling with make and make install of the fourier transform
plug-in for gimp

http://chidge.net/?m=stuff&o=howtos&p=fft

supposed to do forward and reverse

the make error I get is
make: Nothing to be done for `all'.

if I (make install) after the make error, there is no error and it
creates a binary, but the filers don't show up under filters/generic
like the website above says

the binary is call fourier, if I try to run it I get the error
bash: ./fourier: cannot execute binary file: Exec format error

there is something other things called --install-bin and gimptool-2.0,
but if I try to execute them, there are errors

do I have to move the binary somewhere?

I think I have all the libraries, there are no errors that libraries are
needed

I am using this version of Ubuntu Linux
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

and GIMP 2.8.10


I'll be googling around in the mean time...

--
Dale
  #2  
Old October 23rd 14, 01:40 AM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
ray carter
external usenet poster
 
Posts: 59
Default fourier plug-in for gimp

On Wed, 22 Oct 2014 16:44:33 -0400, Dale wrote:

having troubling with make and make install of the fourier transform
plug-in for gimp

http://chidge.net/?m=stuff&o=howtos&p=fft

supposed to do forward and reverse

the make error I get is make: Nothing to be done for `all'.

if I (make install) after the make error, there is no error and it
creates a binary, but the filers don't show up under filters/generic
like the website above says

the binary is call fourier, if I try to run it I get the error bash:
./fourier: cannot execute binary file: Exec format error

there is something other things called --install-bin and gimptool-2.0,
but if I try to execute them, there are errors

do I have to move the binary somewhere?

I think I have all the libraries, there are no errors that libraries are
needed

I am using this version of Ubuntu Linux Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty

and GIMP 2.8.10


I'll be googling around in the mean time...


Have you tried he
http://gmic.sourceforge.net/gimp.shtml
  #3  
Old October 23rd 14, 03:38 AM posted to rec.photo.digital,rec.photo.darkroom,sci.engr.color,sci.image.processing,comp.graphics.apps.gimp
Dale[_2_]
external usenet poster
 
Posts: 137
Default Also:

On 10/22/2014 07:41 PM, philo wrote:
You should really ask on the Ubuntu group there are folks there who know
considerably more than I do


I asked on Ubuntu, someone suggested to run, make clean, first
then I had to run the command that "make install" put out

fourier-0.4.3$ cp fourier /home/dale/.gimp-2.8/plug-ins

it works but the background looks around 50%, if I enlarge it I can see
some of the image

the reverse works too

I'm working off these tutorials
http://www.cs.unm.edu/~brayer/vision/fourier.html
http://homepages.inf.ed.ac.uk/rbf/HIPR2/fourier.htm
http://people.via.ecp.fr/~remi/soft/...n.php3#fourier

the last link has a Yuv transform from RGB, it installed right the same
way, know it is an approximation depending on what RGB, good enough for
me, for now




--
Dale
  #4  
Old October 23rd 14, 03:39 AM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
Dale[_2_]
external usenet poster
 
Posts: 137
Default fourier plug-in for gimp

On 10/22/2014 08:40 PM, ray carter wrote:
On Wed, 22 Oct 2014 16:44:33 -0400, Dale wrote:

having troubling with make and make install of the fourier transform
plug-in for gimp

http://chidge.net/?m=stuff&o=howtos&p=fft

supposed to do forward and reverse

the make error I get is make: Nothing to be done for `all'.

if I (make install) after the make error, there is no error and it
creates a binary, but the filers don't show up under filters/generic
like the website above says

the binary is call fourier, if I try to run it I get the error bash:
./fourier: cannot execute binary file: Exec format error

there is something other things called --install-bin and gimptool-2.0,
but if I try to execute them, there are errors

do I have to move the binary somewhere?

I think I have all the libraries, there are no errors that libraries are
needed

I am using this version of Ubuntu Linux Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty

and GIMP 2.8.10


I'll be googling around in the mean time...


Have you tried he
http://gmic.sourceforge.net/gimp.shtml


I asked on Ubuntu, someone suggested to run, make clean, first
then I had to run the command that "make install" put out

fourier-0.4.3$ cp fourier /home/dale/.gimp-2.8/plug-ins

it works but the background looks around 50%, if I enlarge it I can see
some of the image

the reverse works too

I'm working off these tutorials
http://www.cs.unm.edu/~brayer/vision/fourier.html
http://homepages.inf.ed.ac.uk/rbf/HIPR2/fourier.htm
http://people.via.ecp.fr/~remi/soft/...n.php3#fourier

the last link has a Yuv transform from RGB, it installed right the same
way, know it is an approximation depending on what RGB, good enough for
me, for now


--
Dale
  #5  
Old October 23rd 14, 04:43 PM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
ray carter
external usenet poster
 
Posts: 59
Default fourier plug-in for gimp

On Wed, 22 Oct 2014 16:44:33 -0400, Dale wrote:

having troubling with make and make install of the fourier transform
plug-in for gimp

http://chidge.net/?m=stuff&o=howtos&p=fft

supposed to do forward and reverse

the make error I get is make: Nothing to be done for `all'.

if I (make install) after the make error, there is no error and it
creates a binary, but the filers don't show up under filters/generic
like the website above says

the binary is call fourier, if I try to run it I get the error bash:
./fourier: cannot execute binary file: Exec format error

there is something other things called --install-bin and gimptool-2.0,
but if I try to execute them, there are errors

do I have to move the binary somewhere?

I think I have all the libraries, there are no errors that libraries are
needed

I am using this version of Ubuntu Linux Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty

and GIMP 2.8.10


I'll be googling around in the mean time...


FWIW you should be able to accomplish that with the ImageMagick - convert
command - there is an option for fft and one for ift (inverse fft).
  #6  
Old October 23rd 14, 11:38 PM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
Dale[_2_]
external usenet poster
 
Posts: 137
Default fourier plug-in for gimp

On 10/23/2014 11:43 AM, ray carter wrote:
On Wed, 22 Oct 2014 16:44:33 -0400, Dale wrote:

having troubling with make and make install of the fourier transform
plug-in for gimp

http://chidge.net/?m=stuff&o=howtos&p=fft

supposed to do forward and reverse

the make error I get is make: Nothing to be done for `all'.

if I (make install) after the make error, there is no error and it
creates a binary, but the filers don't show up under filters/generic
like the website above says

the binary is call fourier, if I try to run it I get the error bash:
./fourier: cannot execute binary file: Exec format error

there is something other things called --install-bin and gimptool-2.0,
but if I try to execute them, there are errors

do I have to move the binary somewhere?

I think I have all the libraries, there are no errors that libraries are
needed

I am using this version of Ubuntu Linux Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty

and GIMP 2.8.10


I'll be googling around in the mean time...


FWIW you should be able to accomplish that with the ImageMagick - convert
command - there is an option for fft and one for ift (inverse fft).


thanks, I'll have to learn ImageMagick

--
Dale
  #7  
Old October 24th 14, 03:37 AM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
ray carter
external usenet poster
 
Posts: 59
Default fourier plug-in for gimp

On Thu, 23 Oct 2014 18:38:45 -0400, Dale wrote:

On 10/23/2014 11:43 AM, ray carter wrote:
On Wed, 22 Oct 2014 16:44:33 -0400, Dale wrote:

having troubling with make and make install of the fourier transform
plug-in for gimp

http://chidge.net/?m=stuff&o=howtos&p=fft

supposed to do forward and reverse

the make error I get is make: Nothing to be done for `all'.

if I (make install) after the make error, there is no error and it
creates a binary, but the filers don't show up under filters/generic
like the website above says

the binary is call fourier, if I try to run it I get the error bash:
./fourier: cannot execute binary file: Exec format error

there is something other things called --install-bin and gimptool-2.0,
but if I try to execute them, there are errors

do I have to move the binary somewhere?

I think I have all the libraries, there are no errors that libraries
are needed

I am using this version of Ubuntu Linux Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename:

trusty

and GIMP 2.8.10


I'll be googling around in the mean time...


FWIW you should be able to accomplish that with the ImageMagick -
convert command - there is an option for fft and one for ift (inverse
fft).


thanks, I'll have to learn ImageMagick


Just install it and do 'man convert' - describes fft and ift and, I
think, gives an example.
  #8  
Old October 25th 14, 10:21 PM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
Dale[_2_]
external usenet poster
 
Posts: 137
Default fourier plug-in for gimp

On 10/23/2014 11:43 AM, ray carter wrote:
FWIW you should be able to accomplish that with the ImageMagick - convert
command - there is an option for fft and one for ift (inverse fft).


thanks, got that one too

figured out what was wrong with the gimp one

--
Dale
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GIMP Mike -- Email Ignored Digital SLR Cameras 144 September 13th 08 02:08 PM
DC plug of DMW-AC1 [email protected] Digital Photography 0 February 22nd 06 09:44 AM
Do I want The Gimp??? royroy Digital Photography 52 August 6th 04 04:44 AM
The Gimp Allodoxaphobia Digital Photography 14 July 10th 04 06:59 AM
help with the GIMP Peter Medium Format Photography Equipment 5 April 13th 04 12:28 AM


All times are GMT +1. The time now is 05:34 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2004-2017 PhotoBanter.com.
The comments are property of their posters.