A Photography forum. PhotoBanter.com

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » PhotoBanter.com forum » Digital Photography » Digital Photography
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Lens retraction motor problem with Olympus C700



 
 
Thread Tools Display Modes
  #1  
Old September 27th 04, 03:56 PM
Mark Kyprianou
external usenet poster
 
Posts: n/a
Default Lens retraction motor problem with Olympus C700

I've had two lens motor failures on my Olympus C700 camera. When the
unit is powered on the lens extends and it retracts when the unit is
powered off. In both cases when I tried to power down the unit, the
lens would not retract and a motor/whirring sounds was made. The
camera is a little over two years old and two failures seems
excessive. Has anyone else seen this problem?

thanx, mark
  #2  
Old September 27th 04, 04:27 PM
Julie
external usenet poster
 
Posts: n/a
Default

(Mark Kyprianou) wrote in
:

I've had two lens motor failures on my Olympus C700 camera. When
the unit is powered on the lens extends and it retracts when the
unit is powered off. In both cases when I tried to power down the
unit, the lens would not retract and a motor/whirring sounds was
made. The camera is a little over two years old and two failures
seems excessive. Has anyone else seen this problem?


Mark,

I have a C-700 and a C-730. Both have on occasion refused to retract
as you described, and I've had to remove the batteries to power the
camera off. After reinserting batteries and hitting the power
button, the camera worked as it should, and when powered off, the
lens retracted normally. I didn't consider these failures per se
since the camera recovered immediately.

My C-730 did suffer a true failure after about 9 months of heavy
use. In addition to the lens not retracting, the camera would beep
at me in a consistent pattern when I tried to zoom, press the
shutter, or power off, and removing the batteries, even overnight,
did not resolve the problem. Playback worked fine but I couldn't do
anything else. The camera was still under warranty, so I sent it in
for repair. Olympus replaced the lens assembly and I had it back in
about 3 weeks. It's been more than a year since, and the camera
still works fine. I'm not sure what the life expectancy is on these
things, but considering what mine have been put through, they've
done very well.

If your lens will not retract after removing/reinserting batteries
but seems to work otherwise, check to be sure that the lens assembly
has not become misaligned. Look at the lens from the top and also
along the front edge to see if it's aligned properly with the camera
body. I learned the hard way with the C-700 that the lens can easily
be knocked out of alignment (and now I keep a lens tube adapter on
these cameras at all times for protection), Fortunately, it was also
fairly easy to do a bit of "chiropractic" to get the lens back in
the proper position, though the movement is a bit noisier than it
was prior to the incident.

As of January 2003, the minimum repair charge for a C-700 was $160,
with a complete overhaul running $214 (per
http://www.olympusamerica.com/cpg_se...pair_pricelist.
pdf), so if your problem doesn't resolve itself, replacement would
probably be a better value than repair for you at this point, and if
it does resolve itself, I wouldn't worry about it.

Julie
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help with Olympus C700 Power Problem Fred Digital Photography 22 October 28th 04 07:00 AM
Need Help with Olympus C700 Power Problem Fred 35mm Photo Equipment 25 October 28th 04 07:00 AM
Lens retraction motor problem with Olympus C700 Mark Kyprianou Digital Photography 1 September 27th 04 05:29 PM


All times are GMT +1. The time now is 10:25 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2004-2022 PhotoBanter.com.
The comments are property of their posters.