View Single Post
  #7  
Old October 24th 14, 03:37 AM posted to sci.engr.color,sci.image.processing,comp.graphics.apps.gimp,rec.photo.digital,rec.photo.darkroom
ray carter
external usenet poster
 
Posts: 65
Default fourier plug-in for gimp

On Thu, 23 Oct 2014 18:38:45 -0400, Dale wrote:

On 10/23/2014 11:43 AM, ray carter wrote:
On Wed, 22 Oct 2014 16:44:33 -0400, Dale wrote:

having troubling with make and make install of the fourier transform
plug-in for gimp

http://chidge.net/?m=stuff&o=howtos&p=fft

supposed to do forward and reverse

the make error I get is make: Nothing to be done for `all'.

if I (make install) after the make error, there is no error and it
creates a binary, but the filers don't show up under filters/generic
like the website above says

the binary is call fourier, if I try to run it I get the error bash:
./fourier: cannot execute binary file: Exec format error

there is something other things called --install-bin and gimptool-2.0,
but if I try to execute them, there are errors

do I have to move the binary somewhere?

I think I have all the libraries, there are no errors that libraries
are needed

I am using this version of Ubuntu Linux Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename:

trusty

and GIMP 2.8.10


I'll be googling around in the mean time...


FWIW you should be able to accomplish that with the ImageMagick -
convert command - there is an option for fft and one for ift (inverse
fft).


thanks, I'll have to learn ImageMagick


Just install it and do 'man convert' - describes fft and ift and, I
think, gives an example.